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Important Notice: 

 
This guide assumes some previous knowledge about usage of the System x and Cluster Solutions configurator 

(x-config). Please review the User Manual before attempting these tutorials. 
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Tutorial 1: 28 Node / Ethernet 

 
OBJECTIVE: 

Create a 28 node cluster using x3550 M4 servers, supported by an Ethernet network 

 
SOLUTION: 

1. Click Custom on the Starter screen to create a new cluster. Select Intelligent Cluster. Choose your Country and Region. 

Choose “Full catalog – also include general racking components for special bids (BOM + System x)”.  

2. Select Rack power options as needed. Review and click Finish. 

3. Open the Cluster Preferences via the Preferences menu at the top of the screen. 

4. Make any necessary changes to the Data networks, Ancillary networks, Power, Services, and Software 

tabs. For the purposes of this cluster, use the defaults already selected. 

5. Click Save to save all preferences changes. 

6. Right click on any slot and select the Add option. 

7. Select Server > New Server... 

8. Use the drop down combo box next to Base item and select the x3550 M4 model from the list of server types. 

9. Type “Compute” in the Item label field at the top. This label will help identify this node at a later time. 

10. For the ‘Node role’ use the drop down arrow and select ‘Compute’.  

11. Update the Item color by clicking on the Change color button and selecting a color (for example. red). 

This color will help identify this node at a later time. 

12. Click on the Standard features and services tab. Find the combo box associated with system memory selection (labeled 

“x3550 M4 Memory”) and select the 8GB PC3-12800…LP RDIMM option. Change quantity to 2.  

13. Find the combo box associated with processor selection (labeled “x3550 M4 Processor “) and select the 

QuadCore Intel Xeon Processor E5-2643 option. Then, use the number spinner to the right of the combo 

box and increase the quantity to 2 so the Compute server will have two quad core processors each. 

14. Click on the Storage options tab, and find the combo box associated with storage selection (labeled “x3550 M4 HDD 

Kit”) and select the “IBM System x3550 M4 4x 2.5” HDD Assembly Kit” option. Then, select “IBM 300GB 10K 

6Gbps SAS 2.5” SFF G2HS HDD” from the “SFF Slim SAS - SATA” drop down. Change quantity to 1. 

15. Next clear any fatal red error messages. In this demo go to the Power tab and add in additional x3550 M4 Power Supply.  

16. Click Save to save the new Compute server. 

17. Select the appropriate radio button for creating an exact number of the new items. Then enter 28 in the dialog box that 

appears afterward.  

18. After a few seconds, the new servers will appear in the rack, with the necessary switch added to support them all on the 

main Ethernet network. Additionally all point to point cabling will already be generated and can be seen by highlighting 

over any item in the rack view. 

19. Save the cluster via the File menu at the top of the screen. This allows an autosave to be generated each time changes 

are made from here on. 

20. To create a management node, either create a new Server exactly as done before, or follow these steps to convert one of 

the existing nodes. 

21. Edit the “Compute” server and access the edit mode by right-clicking the server and selecting Edit. 

22. Type “Management” in the Item label field. For the Node role set to Management.  

23. Select a different color for the management node (for example. blue). 

24. For two (2) connections to the Ethernet network, use the number spinner near Management (Ethernet) in the Networks 

tab. 

25. Find the system memory selection again on the Standard features and services tab and choose the “4GB PC3L-

10600…LP UDIMM” option instead of the previous 8GB option. 

26. Find the system processor selection again under the Standard features and services tab and choose the 6 Core Intel 

Xeon Processor E5-2667 option. 

27. Click Save. Choose the save option which saves changes to only a single copy of the item.  

28. Save the cluster again via the File menu. This exercise is complete. 
 



Page 4 of 6 

 

Tutorial 2: 128 Node Blade / Ethernet / Infiniband DDR 

 
OBJECTIVE: 

Create a 128 node configuration using LS22 Blades installed in BCH BladeCenter Chassis with an Infiniband 

DDR compute network 

 
SOLUTION: 

1. Click Custom on the Starter screen to create a new cluster. Select Intelligent Cluster. Choose your Country and Region. 

Choose Full Catalog – also include general racking components for special bids. Select the Rack power. Lastly, 

review selections and select Finish. 

2. Enter the Cluster Preferences (or hit F12) from the Preferences menu at the top of the screen. 

3. Go to the Compute Network section in the Data Networks tab. 

4. Select Infiniband DDR from the Network Type pull down tab. 

5. Keep the default Centralized. 

6. Press the Save button to save changes to the networking. 

7. Highlight over any slot in the empty rack and press the blue Add button (alternatively you may right click 

on any slot and select the Add option), select Blade > New Blade. 

8. Type “Compute” as the Item Label. 

9. Select “Compute” for the Node role. 

10. Select Red from the item change color button. 

11. Select HS22 Base Model from the Base Item combo box. 

12. Put a check mark next to the Compute (Infiniband DDR) box in the Networks tab section to enable a 

connection to this network. The adapter card will automatically be installed. 

NOTE: Blades do not allow specifying the number of connections to a network, since it is controlled by the 

BladeCenter where they are installed. 

13. Select the “4GB PC3-10600 CL9….RDIMM” option from under the Standard features and services tab. 

14. Select the “Intel Xeon Processor E5504 4C…” Processor from under the Standard features and services 

tab. Increase the quantity to 2 using the number spinner box to the right. 

15. Press the Save button. 

16. Choose the Create an exact number of items radio button to create 128 of these nodes. They will automatically be 

installed in the default BCH BladeCenter with 1 connection to the Ethernet and Compute networks. Also note that one 

of the BladeCenter H only has 2 blades due to remainders. 

17. Save the cluster via the File menu. 

18. Edit one of the BladeCenter H with all the blades installed, fix any issues identified. 

19. Press the Save button, and make changes to All. 

20. Finally, select the rack with the most empty space and make a single x3650 M4 Management node with 

four 2GB PC3L – 10600…LP RDIMM, two Quad-Core E5-2609 processors, and one 300GB 10K..” 

SAS Hard Drive. 

21. Save the cluster via the File menu. This exercise is complete. 
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Tutorial 3: 1024 Node / Storage / Tiered Console / Tiered Ethernet / Tiered 

Infiniband FDR10 

 
OBJECTIVE: 

To create a 1024 Node configuration using x3550 M4 servers, tiered Console, tiered Ethernet, and tiered 

Infiniband FDR10 networks 

 
SOLUTION: 

1. Click Custom on the Starter screen to create a new cluster. Choose Intelligent Cluster. 

2. Open Cluster Preferences. 

3. Under Compute network, select Infiniband FDR10 as the type. 

4. Select the Distributed radio button for both the Management (Ethernet) and Compute (Infiniband FDR10) networks. 

5. Use the IBM System Networking RackSwitch G8000 for the Main Management switch, select 24 trunks. 

6. Select 4 trunks for the Leaf Management switch, using the IBM System Networking RackSwitch G8000. 

7. Use the Mellanox SX6036 FDR10 Infiniband Switch for the Main Compute switch, select 24 trunks. 

8. Select 4 trunks for the Leaf Compute switch, using the Mellanox SX6036 FDR10 Infiniband switch. 

9. Go to the Ancillary Networks tab. 

10. Select the Distributed radio button for the Console Network. 

11. Select the IBM Local 2x16 Console Manager switch for the Main Console switch. 

12. Press the Save button to save preferences. 

13. Save the cluster via the File menu. 

14. Add 1024 x3550 M4 Compute servers with one connection to each Console, Management, and Compute networks. 

Configure with the following options: two Quad-Core Intel Xeon Processor Model E5-2643, four 4GB PC3L-10600 

DIMM, two 146 GB 15k SAS drives, and an Brocade 8Gb FC Single Port PCIe HBA (for connection to Storage, found 

under the Expansion options tab).  

15. Save the Cluster via the File menu. 

16. Select a rack which has some empty space and has only 1 copy. 

17. Add four x3550 M4 Management servers with one connection to the Console network and two connections 

to the Management network. Configure the following options: two Quad-Core Intel Xeon Processor E5-

2643, two 4GB PC3L-10600 DIMM and two 300GB 10k SAS drives. 

18. Save the Cluster via the File menu. 

19. Create three new DS3512 Dual Controller in a rack with open space via Add > Storage > New Storage. 

20. Configure the DS3512 with twelve 300GB 15k drives. Save the Storage addition. 

21. Save the Cluster via the File menu. This exercise is complete. 
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Tutorial 4: 128 Node / Ethernet  

 
OBJECTIVE: 

To create a 128 node cluster using x3650 M4 servers, supported by an Ethernet network 

 
SOLUTION: 

1. Click Custom on the Starter screen to create a new cluster. Select Intelligent Cluster. Choose your Country and 

Region.  

2. Select Rack power options as needed. Review and select Finish. 

3. Open the Cluster Preferences via the Preferences menu at the top of the screen. 

4. Make any necessary changes to the Network, Power, Services, and Software tabs. For the purpose of this cluster, use the 

defaults already selected. 

5. Click Save to save all preferences changes. 

6. Highlight over any slot in the empty rack and press the blue Add button (alternatively you may right-click on any slot and 

select the Add option). 

7. Select Server > New Server... 

8. Type “Compute” in the Item label field at the top. This label will help identify this node at a later time. Select “Compute” 

for Node role. 

9. Click on the colored button at the bottom of the field and select a color (for example, red). This color will help identify this 

node at a later time. 

10. Use the drop down combo box next to Base Item and select the x3650 M4 model from the list of server types. 

11. Choose the Standard features and services tab. Find the combo box associated with system memory selection (labeled 

“x3650M4 Memory“) and select four of the 8GB PC3-12800 DDR3 option. 

12. In the combo box associated with processor selection (labeled “x3650M4 Processor“) select the 8C Intel Xeon Processor 

E5-2670 option. Then, use the number spinner to the right of the combo box and increase the quantity to 2 so the Compute 

server will have two 8C processors each. 

13. Find and then select two of the 2.5“ 500GB 7200 NL SATA HDD option from the “SFF Slim SAS SATA “ section on the 

Storage options tab. 

14. Click Save to save the new “Compute” server. 

15. Select the appropriate radio button for creating an exact number of the new items. Then enter 128 in the dialog box that 

appears afterward. 

16. After a few seconds, the new servers will appear in the rack, with the necessary switch added to support them all on the 

main Ethernet network. Additionally all point to point cabling will already be generated and can be seen by moving the 

cursor over any item in the rack view. 

17. Save the cluster via the File menu at the top of the screen. This allows an autosave to be generated with any additional 

changes. 

18. To create a management node, either create a new Server exactly as done before, or follow these steps to convert one of the 

existing nodes. 

19. Highlight over any Compute server and access the edit mode by clicking on the notepad pencil icon that appears on the 

server (this can alternatively be done by right-clicking the server and selecting Edit item). 

20. Type “Management” in the Item label field. 

21. Select a different color for the management node (for example, blue).  

22. For two connections to the Ethernet network, use the number spinner near Management (Ethernet) in the Networks 

section by expanding the Network tab.  

23. Find the system memory selection again under the Main Options tab and choose the 4GB PC3L-10600 DDR3 

option instead of the previous 8GB option.  

24. Find the system processor selection again under the Main Options tab and choose the dual-Core Intel Xeon 

Processor E5-2637.  

25. Click Save. Choose the save option which saves changes to only a single copy of the item.  

26. Save the cluster again via the File menu. This exercise is complete. 
 


